Moodle 3.7 or later requires at least PHP 7.1.0 (currently using version 5.6.40-38+0~20201103.42+debian10~1.gbpb211e0). Some servers may have multiple PHP versions installed, are you using the correct executable?